Standard ACL 2

I denna laboration ska du använda numrerad standard ACL och namngiven standard ACL för att konfigurera följande uppgifter:

  1. Task 1: Host i STUDENTS nätverk får inte komma åt host i TEACHERS nätverk
  2. Task 2: Hosts i HR nätverk får inte komma åt servern i Internet nätverk
  3. Task 3: Endast host i TEACHERS nätverk får använda TELNET för att fjärradministrera R2
  4. Task 4: Endast PC-C får inte komma åt WEB-SRV

Topologi


Instruktioner

Konfigurera Telnet, hostname och console lösenord för router R1

  • Router(config)#hostname R1
  • R1(config)#enable secret enpass
  • R1(config)#line console 0
  • R1(config-line)#password conpass
  • R1(config-line)#login 
  • R1(config-line)#exit
  • R1(config)#line vty 0 4
  • R1(config-line)#password vtypass
  • R1(config-line)#login
  • R1(config-line)#exit
  • R1(config)#

Konfigurera IP-adresser

  • R1(config)#inter g0/0
  • R1(config-if)#description HR
  • R1(config-if)#ip address 192.168.11.1 255.255.255.0
  • R1(config-if)#no shutdown
  • R1(config-if)#exit
  • R1(config)#inter g0/1
  • R1(config-if)#description STUDENTS
  • R1(config-if)#ip address 192.168.12.1 255.255.255.0
  • R1(config-if)#no shutdown
  • R1(config-if)#exit
  • R1(config)#inter s0/0/0
  • R1(config-if)#description TO R2
  • R1(config-if)#ip address 10.10.10.2 255.255.255.252
  • R1(config-if)#no shutdown
  • R1(config-if)#exit 
  • R1(config)#

Konfigurera Telnet, hostname och console lösenord för router R2

  • Router(config)#hostname R2
  • R2(config)#enable secret enpass
  • R2(config)#line console 0
  • R2(config-line)#password conpass
  • R2(config-line)#login
  • R2(config-line)#exit
  • R2(config)#line vty 0 4
  • R2(config-line)#password vtypass
  • R2(config-line)#login
  • R2(config-line)#exit

Konfigurera IP-adresser för router R2

  • R2(config)#inter g0/0
  • R2(config-if)#ip address 192.168.10.1 255.255.255.0
  • R2(config-if)#no shutdown
  • R2(config-if)#exit
  • R2(config)#inter s0/1/0
  • R2(config-if)#description TO ISP
  • R2(config-if)#ip address 196.5.5.2 255.255.255.252
  • R2(config-if)#no shutdown
  • R2(config-if)#exit
  • R2(config)#inter s0/0/0
  • R2(config-if)#description TO R1
  • R2(config-if)#clock rate 64000
  • R2(config-if)#ip address 10.10.10.1 255.255.255.252
  • R2(config-if)#no shutdown
  • R2(config-if)#exit
  • R2(config)#inter s0/0/1
  • R2(config-if)#description TO R3
  • R2(config-if)#ip address 10.10.10.5 255.255.255.252
  • R2(config-if)#no shutdown
  • R2(config-if)#exit

Konfigurera Telnet, hostname och console lösenord för router R3

  • Router(config)#hostname R3
  • R3(config)#enable secret enpass
  • R3(config)#line console 0
  • R3(config-line)#password conpass
  • R3(config-line)#login
  • R3(config-line)#exit
  • R3(config)#line vty 0 4
  • R3(config-line)#password vtypass
  • R3(config-line)#login
  • R3(config-line)#exit

Konfigurera IP-adresser

  • R3(config)#inter g0/0
  • R3(config-if)#description TEACHERS
  • R3(config-if)#ip address 192.168.13.1 255.255.255.0
  • R3(config-if)#no shutdown
  • R3(config-if)#exit
  • R3(config)#inter s0/0/0
  • R3(config-if)#description TO R2
  • R3(config-if)#clock rate 64000
  • R3(config-if)#ip address 10.10.10.6 255.255.255.252
  • R3(config-if)#no shutdown
  • R3(config-if)#exit

Konfigurera hostname och IP-adresser på router ISP

  • Router(config)#hostname ISP
  • ISP(config)#inter s0/1/0
  • ISP(config-if)#description TO R2
  • ISP(config-if)#clock rate 64000
  • ISP(config-if)#ip address 196.5.5.1 255.255.255.252
  • ISP(config-if)#no shutdown
  • ISP(config-if)#exit
  • ISP(config)#inter g0/0
  • ISP(config-if)#description TO Internet-SRV
  • ISP(config-if)#ip address 200.200.200.1 255.255.255.0
  • ISP(config-if)#no shutdown
  • ISP(config-if)#exit

Konfigurera RIP på routrarna R1, R2 och R3

  • R1(config)#router rip
  • R1(config-router)#version 2
  • R1(config-router)#no auto-summary
  • R1(config-router)#network 192.168.11.0
  • R1(config-router)#network 192.168.12.0
  • R1(config-router)#network 10.10.10.0
  • R1(config-router)#exit 
  • R1(config)#
  • R2(config)#router rip
  • R2(config-router)#version 2
  • R2(config-router)#no auto-summary
  • R2(config-router)#network 192.168.10.0
  • R2(config-router)#network 10.10.10.0
  • R2(config-router)#network 10.10.10.4
  • R2(config-router)#exit
  • R2(config)#
  • R3(config)#router rip
  • R3(config-router)#version 2
  • R3(config-router)#no auto-summary
  • R3(config-router)#network 10.10.10.4
  • R3(config-router)#network 192.168.13.0
  • R3(config-router)#exit
  • R3(config)#

Konfigurera en default route på ISP

  • ISP(config)#ip route 0.0.0.0 0.0.0.0 196.5.5.2

Konfigurera en default route på  R2

  • R2(config)#ip route 0.0.0.0 0.0.0.0 196.5.5.1

Konfigurera Redistribution på R2

  • R2(config)#router rip
  • R2(config-router)#default-information originate
  • R2(config-router)#exit
  • R2(config)#

Host i STUDENTS nätverk får inte komma åt host i TEACHERS nätverk

En numrerad standard ACL skapas och tillämpas på router R3 för att blockera host från STUDENTS. Samtidigt får alla andra host från de olika nätverk komma åt host i TEACHERS nätverk.

  • R3(config)#access-list 1 deny 192.168.12.0 0.0.0.255
  • R3(config)#access-list 1 permit any
  • R3(config)#inter g0/0
  • R3(config-if)#ip access-group 1 out
  • R3(config-if)#end
  • R3#show access-lists

Hosts i HR nätverk får inte komma åt servern i Internet nätverk

För att blockera host från HR nätverk skapas en standard namngiven ACL på router R2. ACL tillämpas på interface s0/1/0 utgående.

  • R2(config)#ip access-list standard DENY-HR
  • R2(config-std-nacl)#10 deny 192.168.11.0 0.0.0.255
  • R2(config-std-nacl)#20 permit any
  • R2(config-std-nacl)#exit
  • R2(config)#inter s0/1/0
  • R2(config-if)#ip access-group DENY-HR out
  • R2(config-if)#end

Verifiera att konfigurationerna är rätta och att endast host i HR nätverk inte kommer åt Internet nätverk (ping till servern på Internet nätverk).

  • R2#sh access-lists

Host i TEACHERS nätverk får komma åt router R2 via Telnet

En numrerad standard ACL skapas på router R2. Virtuella terminaler (vty) ska konfigureras för Telnet-trafik.

  • R2(config)#access-list 5 permit 192.168.13.0 0.0.0.255
  • R2(config)#line vty 0 4
  • R2(config-line)#access-class 5 in
  • R2(config-line)#exit
  • R2(config)#

Verifiera att konfigurationerna i ACL är korrekta. Verifiera också att endast host i TEACHERS kan komma åt router R2 via Telnet.

  • R2#sh access-lists

Endast PC-C får inte komma åt WEB-SRV.

En numrerad standard ACL skapas på router R2 och ACL tillämpas som utgående på interface g0/0

  • R2(config)#access-list 6 deny host 192.168.12.11
  • R2(config)#access-list 6 permit any
  • R2(config)#interface g0/0
  • R2(config-if)#ip access-group 6 out
  • R2(config-if)#end

Verifiera att ACL fungerar och att PC-C med IP-adress 192.168.12.11 inte kan komma åt server WEB-SRV.

  • R2#show access-list